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2 Databases 
 

2.1 Overview 

 
To edit or create a database, use the Database Editor.  You can start the editor from the 
Kvaser program group in the start menu. 

2.2 Database Editor 

 

 

Figure 1 The Database Editor 

 
The Database Editor main window consists of the following parts: 
 
1. The main menu 
2. The toolbar 
3. Tabs for switching between 

 The Message/Signal View  

 The Node List  

 The Communication Matrix. 

 The Environment Variables View 
4. The Tree View.  
5. The Message View. 
6. The Layout View. 
7. The Signal View. 
  
 
 

1 2 3 
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2.2.1 The main menu 
 
The main menu consists of two pull-down menus: File and Help. 
 

2.2.1.1 The File menu 
 
The File menu consists of following functions: 
 

 New - With this function you create a new clean database. This function is also available 
by pressing Ctrl+N on the keyboard or pressing the New button in the toolbar. 

 

 Open - With this function you open an existing database. This function is also available 
by pressing Ctrl+O on the keyboard or pressing the Open button in the toolbar. 

 

 Append – With this function you append one database to another.  
 

 Save - With this function you save your database in the current working directory. This 
function is also available by pressing Ctrl+S on the keyboard or pressing the Save button 
in the toolbar. 

 

 Save As - With this function you save your database in the current working directory with 
a new name. 

 

 Exit - With this function you exit the Database Editor. 
 

2.2.1.2 The Help menu 
 
The Help menu consists of the following functions: 
 

 Kvaser Database Editor Help - Click here to access the database editor help pages. 
 

 About - Click here to access the About Box. Useful for determining which version of the 
Database Editor you are running. 

 
 

2.2.2 The toolbar 
 

 

Figure 2: The toolbar 

 
The toolbar consists of the following items: 
 
1. Toolbar detach button - Click here if you want to detach the toolbar from the window. 
 
2. New - With this function you create a new clean database. This function is also available 

by pressing Ctrl+N on the keyboard or clicking File | New in the main menu. 
 
3. Open - With this function you open an existing database. This function is also available 

by pressing Ctrl+O on the keyboard or clicking File | Open in the main menu. 
 
4. Save - With this function you save your database in the current working directory. This 

function is also available by pressing Ctrl+S on the keyboard or clicking File | Save in the 
main menu. 
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5. Delete Messages button - Click here to delete the selected messages from the database. 
 
6. Insert Message button – Click here to insert a new message into the database. 
 
7. Delete Signals button - Click here to delete the selected signals from the database. 
 
8. Insert Signal button – Click here to insert a new signal into the currently selected 

message. 
 
9. Find field – Type a text string to search for among message names and signal names in 

the database. The search function is not case sensitive. Click the Search Down button to 
perform the search. 

 
10. Search Down button – Click here to search the database. The text to search for must be 

typed into the Find field positioned to the left in the toolbar. 
 
11. Expand Signal button – Click here to expand the length of the currently selected signal 

by one bit. 
 
12. Shrink Signal button - Click here to shorten the length of the currently selected signal by 

one bit. 
 
13. Move Signal Up button – Click here to move the signal inside the message one bit 

position up. 
 
14. Move Signal Down button - Click here to move the signal inside the message one bit 

position down. 
 

2.2.3 The Tree View 
 
In the Tree View you can see the current database in a tree structure. The database expands 
to CAN messages, environment variables and nodes. The CAN messages expand in turn to 
signals. 

 

Figure 3 The Tree View 
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Clicking the right mouse button will open a submenu with insert and/or delete items.  The 
contents of this submenu vary based on the tree structure level you have highlighted. 
 
At the database level (root), you will only have Database Overview and Line Up in the 
submenu. The Database Overview submenu item will hide the tree view and you will se the 
message/signal view over the whole window. To view the tree view again, right click on the 
menu bar area (beside File, Tools and Help). 
 
In the tree view it is possible to insert new messages, signals and environment variables to 
your database. To insert a new message into the database right click on CAN messages in 
the tree view and click on the submenu item insert Message. This function is also available by 
pressing the Insert Message button on the toolbar. To insert environment variable or node do 
the same as for insert message.  
 
At the message level you will have the following two items in the submenu: 

 Delete Message - Click here to delete the currently selected message. This function is 
also available by pressing the Delete Message button on the toolbar. 

 Insert Signal - Click here to insert a new signal into the currently selected message. This 
function is also available by pressing the Insert Signal button on the toolbar. 

 
At the signal level, you will only have the Delete Signal item in the submenu. This item 
deletes the currently selected signal. This function is also available by pressing the Delete 
Signal button on the toolbar. 
 
 

2.2.4 The Message View 
 

 

Figure 4 The Message View 

 
In this view each message is presented. If you have created a new message you can set its 
parameters here. The information in the following columns defines the message: 
 

 Message Name - Type the desired name. A new message will be named ‘NewMessage’ 
by default. 

 CAN Identifier - Set up a CAN Identifier for the message. Default Id is 0. 

 Identifier Type - Select Standard or Extended from a dropdown list. Default type is 
Standard. 

 DLC - Select the data length code from a dropdown list. Default DLC is 0. 

 Sending Node - Select a node from dropdown list. Nodes are defined in Node View. 

 Comment – Enter a message description. 
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2.2.5 The Layout View 
 

 

Figure 5: The Layout View 

 
In this view you can see how the bits for each byte in the message are occupied by signals. 
 
As you insert signals, the bits used by the signals will be marked in this view with different 
colors for each signal. 
 

2.2.6 The Signal View 
 

 

Figure 6 The Signal View  

 
In this view, each signal in the selected message is displayed. If you have created a new 
signal, you can set its parameters here. The information in the following columns defines the 
signal: 
 

 Signal Name - Type the desired name. A new signal will be named ‘NewSignal’ by 
default. 

 Type  - Set up the data type of the signal. Alternatives are Signed, Unsigned, Float or 
Double. 

 Format - Select a format from the dropdown list. Alternatives are Intel or Motorola. 
Default is Intel. 

 Mode - Select a mode from the dropdown list. Alternatives are Normal or Mode Signal. 
Default is Normal.  

 Startbit - Select the start position of the signal in the message. Default is 0. 

 Length - Select the length of the signal in bits. Default is 0. 

 Factor – Enter a scaling factor if one is used. Default is 1. 

 Offset – Enter an offset if used. Default is 0. 

 Minimum - Enter the minimum possible signal value. Default is 0. 

 Maximum - Enter the maximum possible signal value. Default is 0. 

 Unit - Enter the unit the signal is represented in. No default. 

 Comment - Enter a description of the signal. 

 Values – Enter an alias for a signal value. 
 



Kvaser Database Editor - User's Guide  9(12) 
 

                            Kvaser AB, Mölndal, Sweden — www.kvaser.com 
 

 
 

2.2.7 The Node List View 
 

 

Figure 7 The Node List View 

 
In this view, the defined nodes in the database are displayed. This is where you insert and 
delete nodes. Clicking the right mouse button Opens a submenu with the following items: 
 

 Delete Node - Click here to delete the currently selected node. 

 Insert Node - Click here to insert a node into the database. 
 
The view consists of following columns: 
 

 Node Name - Type the desired name. A new Node will be named ‘NewNode’ by default. 

 Comment - Enter a description of the node. 
 
When a node is created, the node will appear as a selectable item in the dropdown list in the 
Sending Node column of the Message view. 
 

2.2.8 The Communication Matrix View 
 

 

Figure 8 The Communication Matrix View 

 
The Communication Matrix can be used to associate Network Nodes with Signals. To do this, 
double-click in the Signal's row and Node's column.  
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2.2.9 The Environment Variables View 
 

 

Figure 9 The Environment Variables View 

 

 Environment Variable - The name of the Environment Variable. 

 Type - The data type of the Environment variable. 

 Unit - The Unit of the Environment Variable. 

 Min - The minimum value the Environment Variable can have. 

 Max - The maximum value the Environment Variable can have. 

 Start Value - The start value of the Environment Variable.  

 Comment - An optional comment. 

 Access - The type of access of the Environment Variable (read/write/unrestricted).  

 Values - An Environment Variables can tie a number of symbolic values to it. These are 
specified here.  
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2.3 Glossary 

 
Bit time The time one single bit occupies when sent on the CAN bus. A bit time is 

composed of three parts: tsync (1 time quantum), tseg1 (2 – 16 time quanta) 
and tseg2 (1 – 8 time quanta). A bit time occupies 4 – 25 time quanta.  

 
Extended CAN The same as CAN 2.0B. Message identifiers are 29 bits long. 
 
Prescaler Factor used to scale time quanta from oscillator (usually 16 MHz).  
 
Sampling point Position where a bit is sampled expressed from the start of a bit as a 

percentage of the total bit time. Sample point occurs between tseg1 and 
tseg2. Sample point = (tsync + tseg1) / (tsync + tseg1 + tseg2). 

 
SJW Synchronization Jump Width. Defines the maximum synch compensation 

allowed in one step. Allowed values are 1 – 4 time quanta. High SJW allows a 
wide oscillator tolerance range. This parameter must be the same for all 
nodes in the system. 

 
Standard CAN The same as CAN 2.0A. Message identifiers are 11 bits long. 
 
Time quantum A bit time is conceptually divided into a number of time quanta (typically 8 – 

25). 
 
Tseg1 Length (in time quanta) of the time segment between tsync and the sample 

point. Part of a bit time. 2..16 time quanta. 
 
Tseg2 Length (in time quanta) of the time segment following the sample point. Part 

of a bit time. 1..8 time quanta. 
 
Tsync Length (in time quanta) of the time segment preceding tseg1. Bit time starts 

with tsync. It is used to synchronize nodes on the CAN bus. An edge is 
expected within tsync. Tsync is always one time quantum long. 

 
Working area The working area of the main window shows the actual workspace. The 

working area is always visible and is the place where you work with your 
windows. 

 
Workspace A workspace is used to group windows that you think have something in 

common. The active workspace is viewed in the working area. To change the 
active workspace, click the tabs positioned between the toolbar and the 
working area of the main window. 

2.4 Support 

 
You can obtain support on a time-available basis by sending an email to 
support@kvaser.com. Please contact us for information on our other support options. 
 
Software updates, bug fixes, and so on will be made available on our web site, 
http://www.kvaser.com. 
 
Your opinions are appreciated. Suggestions and bug reports may be sent by e-mail to 
support@kvaser.com - if you require a reply, please contact us for more information about 
our support packages. 
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3 Document revision history 
 
 

Revision Date Changes 

1 2005-03 Original revision 

2 2006-11-02 Reviewed – no major changes 

 
 


	Kvaser Database Editor  User’s Guide
	Table of Contents
	Databases
	Overview
	Database Editor
	The main menu
	The File menu
	The Help menu

	The toolbar
	The Tree View
	The Message View
	The Layout View
	The Signal View
	The Node List View
	The Communication Matrix View
	The Environment Variables View

	Glossary
	Support

	Document revision history

